
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<link rel="stylesheet" href="https://www.berthoudrecorder.com/wp-content/themes/Recorder_final/style.css" type="text/css" media="screen" />
<link rel="stylesheet" href="https://www.berthoudrecorder.com/wp-content/themes/Recorder_final/pagenavi-css.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="Recorder Online RSS Feed" href="https://www.berthoudrecorder.com/feed/" />
<meta name="alexaVerifyID" content="Vn2_ZVZ_BcTKsB76XccJLWscL_8" />
<link rel="pingback" href="https://www.berthoudrecorder.com/xmlrpc.php" />
<!--[if lte IE 6]>
	<script defer type="text/javascript" src="https://www.berthoudrecorder.com/wp-content/themes/Recorder_final/js/pngfix.js"></script>
	<![endif]-->




	
		<!-- All in One SEO 4.1.8 -->
		<title>Obituary: Danita “DD” Holst | Recorder Online</title>
		<meta name="description" content="There will be no funeral, but there will be a celebration of life with family in Colorado at a later date." />
		<meta name="robots" content="max-image-preview:large" />
		<meta name="keywords" content="berthoud high school,dd holst,nesseth,obituary" />
		<link rel="canonical" href="https://www.berthoudrecorder.com/obituary-danita-dd-holst/" />
		<meta property="og:locale" content="en_US" />
		<meta property="og:site_name" content="Recorder Online | News for Norther Colorado and the world" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Obituary: Danita “DD” Holst | Recorder Online" />
		<meta property="og:description" content="There will be no funeral, but there will be a celebration of life with family in Colorado at a later date." />
		<meta property="og:url" content="https://www.berthoudrecorder.com/obituary-danita-dd-holst/" />
		<meta property="article:published_time" content="2022-02-27T21:39:01+00:00" />
		<meta property="article:modified_time" content="2022-03-02T00:30:31+00:00" />
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:title" content="Obituary: Danita “DD” Holst | Recorder Online" />
		<meta name="twitter:description" content="There will be no funeral, but there will be a celebration of life with family in Colorado at a later date." />
		<meta name="google" content="nositelinkssearchbox" />
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/www.berthoudrecorder.com\/#website","url":"https:\/\/www.berthoudrecorder.com\/","name":"Recorder Online","description":"News for Norther Colorado and the world","inLanguage":"en-US","publisher":{"@id":"https:\/\/www.berthoudrecorder.com\/#organization"}},{"@type":"Organization","@id":"https:\/\/www.berthoudrecorder.com\/#organization","name":"Recorder Online","url":"https:\/\/www.berthoudrecorder.com\/"},{"@type":"BreadcrumbList","@id":"https:\/\/www.berthoudrecorder.com\/obituary-danita-dd-holst\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/www.berthoudrecorder.com\/#listItem","position":1,"item":{"@type":"WebPage","@id":"https:\/\/www.berthoudrecorder.com\/","name":"Home","description":"News and information for Larimer, Weld and Northern Boulder County Colorado","url":"https:\/\/www.berthoudrecorder.com\/"},"nextItem":"https:\/\/www.berthoudrecorder.com\/obituary-danita-dd-holst\/#listItem"},{"@type":"ListItem","@id":"https:\/\/www.berthoudrecorder.com\/obituary-danita-dd-holst\/#listItem","position":2,"item":{"@type":"WebPage","@id":"https:\/\/www.berthoudrecorder.com\/obituary-danita-dd-holst\/","name":"Obituary: Danita \"DD\" Holst","description":"There will be no funeral, but there will be a celebration of life with family in Colorado at a later date.","url":"https:\/\/www.berthoudrecorder.com\/obituary-danita-dd-holst\/"},"previousItem":"https:\/\/www.berthoudrecorder.com\/#listItem"}]},{"@type":"Person","@id":"https:\/\/www.berthoudrecorder.com\/author\/piper\/#author","url":"https:\/\/www.berthoudrecorder.com\/author\/piper\/","name":"Gary Wamsley","image":{"@type":"ImageObject","@id":"https:\/\/www.berthoudrecorder.com\/obituary-danita-dd-holst\/#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/6589c824a6180d54ebe1282b4a89b8ea?s=96&d=mm&r=g","width":96,"height":96,"caption":"Gary Wamsley"}},{"@type":"WebPage","@id":"https:\/\/www.berthoudrecorder.com\/obituary-danita-dd-holst\/#webpage","url":"https:\/\/www.berthoudrecorder.com\/obituary-danita-dd-holst\/","name":"Obituary: Danita \u201cDD\u201d Holst | Recorder Online","description":"There will be no funeral, but there will be a celebration of life with family in Colorado at a later date.","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/www.berthoudrecorder.com\/#website"},"breadcrumb":{"@id":"https:\/\/www.berthoudrecorder.com\/obituary-danita-dd-holst\/#breadcrumblist"},"author":"https:\/\/www.berthoudrecorder.com\/author\/piper\/#author","creator":"https:\/\/www.berthoudrecorder.com\/author\/piper\/#author","datePublished":"2022-02-27T21:39:01-07:00","dateModified":"2022-03-02T00:30:31-07:00"},{"@type":"Article","@id":"https:\/\/www.berthoudrecorder.com\/obituary-danita-dd-holst\/#article","name":"Obituary: Danita \u201cDD\u201d Holst | Recorder Online","description":"There will be no funeral, but there will be a celebration of life with family in Colorado at a later date.","inLanguage":"en-US","headline":"Obituary: Danita \"DD\" Holst","author":{"@id":"https:\/\/www.berthoudrecorder.com\/author\/piper\/#author"},"publisher":{"@id":"https:\/\/www.berthoudrecorder.com\/#organization"},"datePublished":"2022-02-27T21:39:01-07:00","dateModified":"2022-03-02T00:30:31-07:00","articleSection":"Obituaries, Berthoud High School, DD Holst, Nesseth, obituary","mainEntityOfPage":{"@id":"https:\/\/www.berthoudrecorder.com\/obituary-danita-dd-holst\/#webpage"},"isPartOf":{"@id":"https:\/\/www.berthoudrecorder.com\/obituary-danita-dd-holst\/#webpage"},"image":{"@type":"ImageObject","@id":"https:\/\/www.berthoudrecorder.com\/#articleImage","url":"https:\/\/www.berthoudrecorder.com\/wp-content\/uploads\/2022\/02\/DD-Nesseth-Holst-obit.png","width":328,"height":500}}]}
		</script>
		<!-- All in One SEO -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Recorder Online &raquo; Obituary: Danita &#8220;DD&#8221; Holst Comments Feed" href="https://www.berthoudrecorder.com/obituary-danita-dd-holst/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.4.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-11821241-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.berthoudrecorder.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=9976829c1b9c078a4341f3097e513ce7"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.berthoudrecorder.com/wp-includes/css/dist/block-library/style.min.css?ver=9976829c1b9c078a4341f3097e513ce7' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<script type='text/javascript' src='https://www.berthoudrecorder.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.berthoudrecorder.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.berthoudrecorder.com","hash_tracking":"false","ua":"UA-11821241-1","v4_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.berthoudrecorder.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.4.0' id='monsterinsights-frontend-script-js'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.berthoudrecorder.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.berthoudrecorder.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.berthoudrecorder.com/?p=41950' />
<link rel="alternate" type="application/json+oembed" href="https://www.berthoudrecorder.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.berthoudrecorder.com%2Fobituary-danita-dd-holst%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.berthoudrecorder.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.berthoudrecorder.com%2Fobituary-danita-dd-holst%2F&#038;format=xml" />

			<!-- Global site tag (gtag.js) - Google Analytics -->
			<script async src="https://www.googletagmanager.com/gtag/js?id=  4/jPON5MPdO6w54W0rES_HouU6cvSoVffiiN2qqO5SF4k"></script>
			<script>
				window.dataLayer = window.dataLayer || [];
				function gtag(){dataLayer.push(arguments);}
				gtag('js', new Date());
				gtag( 'config', '  4/jPON5MPdO6w54W0rES_HouU6cvSoVffiiN2qqO5SF4k' );
			</script>

			<link rel="canonical" href="https://www.berthoudrecorder.com/obituary-danita-dd-holst/" />
<meta name="description" content="There will be no funeral, but there will be a celebration of life with family in Colorado at a later date." />
<meta property="og:title" content="Obituary: Danita &quot;DD&quot; Holst" />
<meta property="og:url" content="https://www.berthoudrecorder.com/obituary-danita-dd-holst/" />
<meta property="og:type" content="article" />
<meta property="article:published_time" content="2022-02-27T14:39:01-07:00" />
<meta property="article:modified_time" content="2022-03-01T17:30:31-07:00" />
<meta property="og:updated_time" content="2022-03-01T17:30:31-07:00" />
<meta property="og:description" content="There will be no funeral, but there will be a celebration of life with family in Colorado at a later date." />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Obituary: Danita &quot;DD&quot; Holst" />
<meta name="twitter:description" content="There will be no funeral, but there will be a celebration of life with family in Colorado at a later date." />


<!-- VARVEE HEAD -->
</head>


<body data-rsssl=1>








<!-- VARVEE BODY START -->
<div id="wrapper">

<div id="maincontainer">

<div id="sitetitle">

	<div class="widgetleft">
	<div class="widget"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>March 2022</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr>
		<td colspan="2" class="pad">&nbsp;</td><td id="today"><a href="https://www.berthoudrecorder.com/2022/03/01/" aria-label="Posts published on March 1, 2022">1</a></td><td>2</td><td>3</td><td>4</td><td>5</td>
	</tr>
	<tr>
		<td>6</td><td>7</td><td>8</td><td>9</td><td>10</td><td>11</td><td>12</td>
	</tr>
	<tr>
		<td>13</td><td>14</td><td>15</td><td>16</td><td>17</td><td>18</td><td>19</td>
	</tr>
	<tr>
		<td>20</td><td>21</td><td>22</td><td>23</td><td>24</td><td>25</td><td>26</td>
	</tr>
	<tr>
		<td>27</td><td>28</td><td>29</td><td>30</td><td>31</td>
		<td class="pad" colspan="2">&nbsp;</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://www.berthoudrecorder.com/2022/02/">&laquo; Feb</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></div><div class="widget"><h2>Nebula</h2><img width="150" height="152" src="https://www.berthoudrecorder.com/wp-content/uploads/2011/02/north_america_spitzer_3000-300x303.jpg" class="image wp-image-19328  attachment-150x152 size-150x152" alt="Click for Larger image" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://www.berthoudrecorder.com/wp-content/uploads/2011/02/north_america_spitzer_3000-300x303.jpg 300w, https://www.berthoudrecorder.com/wp-content/uploads/2011/02/north_america_spitzer_3000-75x75.jpg 75w, https://www.berthoudrecorder.com/wp-content/uploads/2011/02/north_america_spitzer_3000-670x677.jpg 670w" sizes="(max-width: 150px) 100vw, 150px" /></div>
		<div class="widget">
		<h2>Recent post</h2>
		<ul>
											<li>
					<a href="https://www.berthoudrecorder.com/berthoud-fire-calls-february-2022/">Berthoud Fire Calls-February 2022</a>
									</li>
											<li>
					<a href="https://www.berthoudrecorder.com/how-bad-would-it-have-to-get-in-ukraine-for-trump-to-abandon-putin/">How bad would it have to get in Ukraine for Trump to abandon Putin?</a>
									</li>
											<li>
					<a href="https://www.berthoudrecorder.com/obituary-danita-dd-holst/" aria-current="page">Obituary: Danita &#8220;DD&#8221; Holst</a>
									</li>
											<li>
					<a href="https://www.berthoudrecorder.com/obituary-kenneth-martin-markham/">Obituary: Kenneth Martin Markham</a>
									</li>
											<li>
					<a href="https://www.berthoudrecorder.com/berthoud-police-blotter-january-2022/">Berthoud Police Blotter-January 2022</a>
									</li>
					</ul>

		</div>	</div>

	<div class="logo">	<a href="https://www.berthoudrecorder.com"><img src="https://www.berthoudrecorder.com/wp-content/themes/Recorder_final/images/Recorder_Online_Flag_400px.png" alt="Recorder Online" border="0"></a>
	</div>
	
	<div class="tagline"> News for Norther Colorado and the world </div>

	<div class="widgetright">
		</div>

	<div class="clear"></div>
	<br clear="both">
</div>


<div id="recorder-navbar">
	<ul id="recordernav">
		<li><a href="https://www.berthoudrecorder.com">Home</a></li>
        <li class="cat-item"><a href="#">Sections</a>
			<ul class="children">	<li class="cat-item cat-item-1"><a href="https://www.berthoudrecorder.com/category/area_news/">Area News</a>
<ul class='children'>
	<li class="cat-item cat-item-2"><a href="https://www.berthoudrecorder.com/category/area_news/local-news/">Local News</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://www.berthoudrecorder.com/category/area_news/school-news/">School News</a>
</li>
	<li class="cat-item cat-item-52"><a href="https://www.berthoudrecorder.com/category/area_news/police-beat/">Police Beat</a>
</li>
	<li class="cat-item cat-item-53"><a href="https://www.berthoudrecorder.com/category/area_news/fire-beat/">Fire Beat</a>
</li>
	<li class="cat-item cat-item-56"><a href="https://www.berthoudrecorder.com/category/area_news/town-briefs/">Town Briefs</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-3"><a href="https://www.berthoudrecorder.com/category/business-news/">Business News</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://www.berthoudrecorder.com/category/features/">Features</a>
</li>
	<li class="cat-item cat-item-8"><a href="https://www.berthoudrecorder.com/category/sports/">Sports</a>
</li>
	<li class="cat-item cat-item-9"><a href="https://www.berthoudrecorder.com/category/variety/">Variety</a>
<ul class='children'>
	<li class="cat-item cat-item-57"><a href="https://www.berthoudrecorder.com/category/variety/our-natural-world/">Our Natural World</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-11"><a href="https://www.berthoudrecorder.com/category/voices-thoughts/">Voices &amp; Thoughts</a>
<ul class='children'>
	<li class="cat-item cat-item-16"><a href="https://www.berthoudrecorder.com/category/voices-thoughts/guest-column/">Guest column</a>
</li>
	<li class="cat-item cat-item-18"><a href="https://www.berthoudrecorder.com/category/voices-thoughts/letters-to-the-editor/">Letters to the Editor</a>
</li>
	<li class="cat-item cat-item-60"><a href="https://www.berthoudrecorder.com/category/voices-thoughts/obituaries/">Obituaries</a>
</li>
	<li class="cat-item cat-item-2589"><a href="https://www.berthoudrecorder.com/category/voices-thoughts/wedding-engagement/" title="A place for wedding and engagement announcements">Weddings and Engagements</a>
</li>
	<li class="cat-item cat-item-10867"><a href="https://www.berthoudrecorder.com/category/voices-thoughts/opcom/">Opinion/Commentary</a>
</li>
</ul>
</li>
	<li class="cat-item cat-item-14"><a href="https://www.berthoudrecorder.com/category/political-politicians/">Political &amp; Politicians</a>
</li>
	<li class="cat-item cat-item-59"><a href="https://www.berthoudrecorder.com/category/earth-sky/">Earth &amp; Sky</a>
</li>
	<li class="cat-item cat-item-156"><a href="https://www.berthoudrecorder.com/category/photo-essays/">Photo Essays</a>
</li>
	<li class="cat-item cat-item-403"><a href="https://www.berthoudrecorder.com/category/agriculture/" title="News of interest to and about agriculture.">Agriculture</a>
</li>
	<li class="cat-item cat-item-1076"><a href="https://www.berthoudrecorder.com/category/county-news/">County/State/Federal</a>
<ul class='children'>
	<li class="cat-item cat-item-6279"><a href="https://www.berthoudrecorder.com/category/county-news/colorado-state-news/">Colorado Agencies</a>
</li>
	<li class="cat-item cat-item-6292"><a href="https://www.berthoudrecorder.com/category/county-news/federal-county-news/" title="Press releases from Federal Agencies">U.S. Federal Agencies</a>
</li>
	<li class="cat-item cat-item-6293"><a href="https://www.berthoudrecorder.com/category/county-news/larimer-county-news/">Larimer County</a>
	<ul class='children'>
	<li class="cat-item cat-item-1077"><a href="https://www.berthoudrecorder.com/category/county-news/larimer-county-news/county-commissioners/" title="Commissioners agendas and meetings">County Commissioners</a>
</li>
	<li class="cat-item cat-item-1078"><a href="https://www.berthoudrecorder.com/category/county-news/larimer-county-news/county-agency-news/">County Agency News</a>
</li>
	<li class="cat-item cat-item-1085"><a href="https://www.berthoudrecorder.com/category/county-news/larimer-county-news/parks-and-open-space/">County Outdoors</a>
</li>
	</ul>
</li>
</ul>
</li>
	<li class="cat-item cat-item-2054"><a href="https://www.berthoudrecorder.com/category/faith/" title="Religion and Church announcements/programs">Faith</a>
</li>
	<li class="cat-item cat-item-5618"><a href="https://www.berthoudrecorder.com/category/crime-justice/" title="Arrests, trials not in immediate area or more newsworthy">Crime and Justice</a>
</li>
	<li class="cat-item cat-item-6280"><a href="https://www.berthoudrecorder.com/category/university-2/" title="News and press releases from Colorado Universities, including CSU, CU, UNC, AFA etc">Colorado Universities</a>
</li>
	<li class="cat-item cat-item-6790"><a href="https://www.berthoudrecorder.com/category/charity-fund/">Charity Events</a>
</li>
	<li class="cat-item cat-item-7956"><a href="https://www.berthoudrecorder.com/category/history-2/">History</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://www.berthoudrecorder.com/category//community-news/">Community News</a>
</li>
	<li class="cat-item cat-item-6046"><a href="https://www.berthoudrecorder.com/category//national-world/">National &amp; World News</a>
</li>
	</ul>
<li class="page_item page-item-13703 page_item_has_children"><a href="https://www.berthoudrecorder.com/events/">Events/Announcements</a>
<ul class='children'>
	<li class="page_item page-item-13699"><a href="https://www.berthoudrecorder.com/events/announcements/">Announcements</a></li>
	<li class="page_item page-item-4031"><a href="https://www.berthoudrecorder.com/events/calendar/">Calendar</a></li>
	<li class="page_item page-item-21286"><a href="https://www.berthoudrecorder.com/events/pulliam-story/">Pulliam Story</a></li>
</ul>
</li>
<li class="page_item page-item-26194"><a href="https://www.berthoudrecorder.com/arts-entertainment/">Arts &#038; Entertainment</a></li>
<li class="page_item page-item-2970 page_item_has_children"><a href="https://www.berthoudrecorder.com/about/">About</a>
<ul class='children'>
	<li class="page_item page-item-4408"><a href="https://www.berthoudrecorder.com/about/policies/">Policies</a></li>
	<li class="page_item page-item-2662"><a href="https://www.berthoudrecorder.com/about/contact/">Contact</a></li>
	<li class="page_item page-item-2246"><a href="https://www.berthoudrecorder.com/about/advertising/">Advertising</a></li>
	<li class="page_item page-item-2652"><a href="https://www.berthoudrecorder.com/about/privacy/">Privacy</a></li>
</ul>
</li>
</div>

<div class="datesearch">
<div class="date">Wednesday, March 2, 2022</div>
<div class="twitterindex"><a href="http://www.twitter.com/berthoudrecordr?>"class="twitter" title="Follow Us!" target="_blank"></a></div>
<div class="rssindex"><a href="https://www.berthoudrecorder.com/feed/" class="rss" title="Subscribe to Recorder Online RSS">Subscribe</a></div>
<div class="search"><form method="get" id="searchform" action="https://www.berthoudrecorder.com/">
<div id="searchbox">
	<div class="searchinputbox"><input type="text" size="25" value="" name="s" class="searchinput" id="s" /></div>
	<div class="searchsubmitbutton"><input type="submit" id="searchsubmit" value="Search" class="searchbutton" /></div>
</div>
</form></div></div>

<div id="contentcontainer"><div id="content">
<div class="postareasingle">


				

            <h2 class="singletitle"><a href="https://www.berthoudrecorder.com/obituary-danita-dd-holst/" rel="bookmark" title="Permanent link to Obituary: Danita &#8220;DD&#8221; Holst">Obituary: Danita &#8220;DD&#8221; Holst</a></h2>
			

			<div class="entry">
							
			<p><img class="alignleft size-medium wp-image-41951" src="https://www.berthoudrecorder.com/wp-content/uploads/2022/02/DD-Nesseth-Holst-obit-262x400.png" alt="" width="262" height="400" srcset="https://www.berthoudrecorder.com/wp-content/uploads/2022/02/DD-Nesseth-Holst-obit-262x400.png 262w, https://www.berthoudrecorder.com/wp-content/uploads/2022/02/DD-Nesseth-Holst-obit-49x75.png 49w, https://www.berthoudrecorder.com/wp-content/uploads/2022/02/DD-Nesseth-Holst-obit.png 328w" sizes="(max-width: 262px) 100vw, 262px" /></p>
<h3 class="title">1961-2022</h3>
<p>Danita Dawn Holst was born on January 16, 1961 and passed away peacefully on February 17, 2022.</p>
<p>Danita (always known as “DD”) was born in Faribault, Minnesota to John and Dottie Nesseth.  She spent her early years growing up in rural Minnesota where she grew up as a “tomboy”, enjoying horseback riding, caring for the farm animals, playing in the snow, and snowmobiling.  Her family had a strong Christian faith, so many of DD’s activities were centered on her church, including lifeguarding at their summer camp, along with her older brother Jay (which she really loved). </p>
<p>DD moved to Berthoud, Colorado in 1977, attended Berthoud High, and graduated in 1979.  During those years in school, DD was popular and well-liked by all who knew her, was a cheerleader, sang in the school choir, and was especially athletic in track; always the final leg in the 400 meter relay and faster than many of the boys!</p>
<p>The love of DD’s life was Greg Holst, whom she met in high school and then in 1983 at a health club where Greg was an athletic trainer.  They married June 15, 1985.</p>
<p>DD and Greg lived in Whittier, CA, 1985 through 1990 while Greg was attending Chiropractic College.  They then moved to Denver, CO for Greg to attend and finish medical school in 1995 and then to Fort Collins, CO for his residency in 1998.  DD was always a hard worker following high school graduation until she settled on becoming a certified optician which she did for 20 years.  Their beautiful daughter Jaynah was then born there on May 12, 1998.</p>
<p>DD’s family moved to rural Phillips County (eastern Colorado) for Greg to pursue his dream of being a rural family physician.  DD enjoyed being a mother, made a lot of new friends, continued to enjoy her Church activities and then their wonderful son Sean was born, April 16, 2002.  She became a member of an acapella quartet, performing throughout Phillips County and became a member of the local hospital foundation, enjoying helping with fundraising.  Her most cherished times at this time in her life continued to be a mother and spending time with family.  When the children were young, they would always have a 2-week summer drive trip where they visited many of the state and national parks in the western states.  DD especially liked gathering rocks as souvenirs from various sites.</p>
<p>In 2007 DD and her family relocated to Eureka, CA when her husband took a new job at the Eureka Family Practice, the family continued to love outdoor activities, including camping at Ruth Lake with friends and again, summer vacation drive trips.  With the children in school, DD decided to work again and worked at St. Joseph Hospital in various capacities – the hospital foundation, pharmacy, and radiation oncology, and worked until she was no longer able.</p>
<p>During her years in Eureka, DD continued to have her faith direct all aspects of her Christian life and sang in her church choir, and above all, put her family above all things.  DD was loved by all who had the privilege of knowing her and after so many years of illness, she is now with her Lord and Savior and no longer suffering.</p>
<p>Danita Dawn is survived by her husband, Gregory Holst, M.D., daughter Jaynah Holst and Sean Holst.  Her surviving extended family includes Father, John (Linda) Nesseth, Mother, Dottie Browning, Brothers and Sister: Jay (Stacey) Nesseth, Jerry (Tracy) Nesseth, Jason (Lori) Nesseth, and Debbie (David) Benson, along with Father In-law &amp; Mother In-law, Dale &amp; Shirley Holst &amp; many Sister In-laws, Brother In-laws, Nephews and Nieces.  DD also had many extended family members in Minnesota (Uncles, Aunts, and Cousins).</p>
<p>The family would like to thank Eureka Rehabilitation and Wellness Center, along with Dr. Lei Han, for the great care DD received while under their care for the last 2 years of her life.</p>
<p>There will be no funeral, but there will be a celebration of life with family in Colorado at a later date.</p>
<p>In lieu of flowers, donations can be made to the Alzheimer’s Association or UCSF Memory and Aging</p>
<p><a href="https://lostcoastoutpost.com/2022/feb/23/obituary-danita-dd-holst-1961-2022/">From the Lost Coast Outpost, Humboldt County, California</a></p>
						<a href="https://www.berthoudrecorder.com/obituary-danita-dd-holst/print/" title="Print This Post" rel="nofollow"><img class="WP-PrintIcon" src="https://www.berthoudrecorder.com/wp-content/plugins/wp-print/images/print.gif" alt="Print This Post" title="Print This Post" style="border: 0px;" /></a>&nbsp;<a href="https://www.berthoudrecorder.com/obituary-danita-dd-holst/print/" title="Print This Post" rel="nofollow">Print This Post</a>
 
			<div class="tags">Related Keywords: <a href="https://www.berthoudrecorder.com/tag/berthoud-high-school/" rel="tag">Berthoud High School</a>, <a href="https://www.berthoudrecorder.com/tag/dd-holst/" rel="tag">DD Holst</a>, <a href="https://www.berthoudrecorder.com/tag/nesseth/" rel="tag">Nesseth</a>, <a href="https://www.berthoudrecorder.com/tag/obituary/" rel="tag">obituary</a></div>
					<div class="bnavigation">
						<div class="bnavleft"><b>Previous Story:</b> <a href="https://www.berthoudrecorder.com/obituary-kenneth-martin-markham/" rel="prev">Obituary: Kenneth Martin Markham</a></div>
						<div class="bnavright"><b>Next Story:</b> <a href="https://www.berthoudrecorder.com/how-bad-would-it-have-to-get-in-ukraine-for-trump-to-abandon-putin/" rel="next">How bad would it have to get in Ukraine for Trump to abandon Putin?</a></div>
					</div>
			</div><!--close div class entry-->
			<div class="clear">
           </br>
		               </div>
				

										<div class="commentarea">
						
<!-- You can start editing here. -->
<div class="commentareain">


			<!-- If comments are open, but there are no comments. -->
        <p> There are no comments yet. Be the first to comment on this article.</p>

	 

</br>
<div id="respond">
<h3>Leave a Reply </h3>

	
	<form action="https://www.berthoudrecorder.com/wp-comments-post.php" method="post" id="commentform">

	
	<p><input type="text" name="author" id="author" value="" size="22" tabindex="1" aria-required='true' />
	<label for="author"><small>Name (required)</small></label></p>

	<p><input type="text" name="email" id="email" value="" size="22" tabindex="2" aria-required='true' />
	<label for="email"><small>e-Mail (will not be published) (required)</small></label></p>


		
	<p><textarea name="comment" id="comment" cols="100%" rows="5" tabindex="4"></textarea></p>

	
	
	<p><input name="submit" type="submit" id="submit" tabindex="5" class="commentsubmit" value="Submit Comment" />
	<input type='hidden' name='comment_post_ID' value='41950' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
	</p>


	</form>


</div><!--close div id respond-->
</div>

                        
					</div>
					
	
</div><!--end postareasingle-->
<div id="postsidebar">
<div class="logo">
  <a href="https://www.berthoudrecorder.com">
  <img src="https://www.berthoudrecorder.com/wp-content/themes/Recorder_final/images/Recorder_Flag_200px.png" alt="Recorder Online" />
    </a>
     <h1><a href="https://www.berthoudrecorder.com">" title="Recorder Online">
         Recorder Online</a>
     </h1
></div>
<div class="postsidebarcontent">
	<div id="postmeta">
		<div class="byline">Added: February 27, 2022<br/>
		Category: <a href="https://www.berthoudrecorder.com/category/voices-thoughts/obituaries/" rel="category tag">Obituaries</a><br/>
		
		</div>
	</div><!--close postmeta-->

		<div class="widget">
			<div id="share1">
			<ul>
            <li><a href="http://twitter.com/home?status=Currently Reading ::'Obituary%3A+Danita+%26%238220%3BDD%26%238221%3B+Holst'%20@%20https://tinyurl.com/ydb3y29f" title="Tweet This!"><img src="https://www.berthoudrecorder.com/wp-content/themes/Recorder_final/images/ico-twitter_250.gif" alt="Twitter This!" border="0"/></a></li>
              </ul>
              </div>
		</div>

		<div class="widget">
</div>
		</div>

	
</div><!--close postsidebarcontent-->
<div class="postsidebarbottom">
			<div class="morefromcat">
						

		<h2><a href="https://www.berthoudrecorder.com/category/voices-thoughts/obituaries/">More from this section</a></h2>

			

				  		
				  					
						<div class="excerpt">

						
												<a href="https://www.berthoudrecorder.com/obituary-kenneth-martin-markham/" rel="bookmark" title="Permanent Link to Obituary: Kenneth Martin Markham"><img src="https://www.berthoudrecorder.com/wp-content/themes/Recorder_final/cropper.php?src=/wp-content/uploads/2022/02/Ketteth-Markham-Obit-photo-75x75.png&amp;h=50&amp;w=50&amp;zc=1&amp;q=95" alt="Obituary: Kenneth Martin Markham" /></a>
											
											<h3><a href="https://www.berthoudrecorder.com/obituary-kenneth-martin-markham/" rel="bookmark" title="Read :: Obituary: Kenneth Martin Markham">
											Obituary: Kenneth Martin &raquo;</a>
											</h3>

										<p>A memorial dedicated to celebrate the life of Kenneth M. Markham                 
                 <a class="morelink" href="https://www.berthoudrecorder.com/obituary-kenneth-martin-markham/" rel="bookmark" title="Read :: Obituary: Kenneth Martin Markham">... Full Story</a></p>
                 
                 </div>

						
						<div class="excerpt">

						
												<a href="https://www.berthoudrecorder.com/obituary-betty-lou-greene/" rel="bookmark" title="Permanent Link to Obituary: Betty Lou Greene"><img src="https://www.berthoudrecorder.com/wp-content/themes/Recorder_final/cropper.php?src=/wp-content/uploads/2021/08/Obituary_cross-of-death-56x75.png&amp;h=50&amp;w=50&amp;zc=1&amp;q=95" alt="Obituary: Betty Lou Greene" /></a>
											
											<h3><a href="https://www.berthoudrecorder.com/obituary-betty-lou-greene/" rel="bookmark" title="Read :: Obituary: Betty Lou Greene">
											Obituary: Betty Lou &raquo;</a>
											</h3>

										<p>Services will be held at First Presbyterian Church in Berthoud on                 
                 <a class="morelink" href="https://www.berthoudrecorder.com/obituary-betty-lou-greene/" rel="bookmark" title="Read :: Obituary: Betty Lou Greene">... Full Story</a></p>
                 
                 </div>

						
						<div class="excerpt">

						
												<a href="https://www.berthoudrecorder.com/obituary-shannon-sam-waldo/" rel="bookmark" title="Permanent Link to Obituary: Shannon &#8216;Sam&#8217; Waldo"><img src="https://www.berthoudrecorder.com/wp-content/themes/Recorder_final/cropper.php?src=/wp-content/uploads/2021/06/Sam-Waldo-Obit-photo-56x75.png&amp;h=50&amp;w=50&amp;zc=1&amp;q=95" alt="Obituary: Shannon &#8216;Sam&#8217; Waldo" /></a>
											
											<h3><a href="https://www.berthoudrecorder.com/obituary-shannon-sam-waldo/" rel="bookmark" title="Read :: Obituary: Shannon &#8216;Sam&#8217; Waldo">
											Obituary: Shannon &raquo;</a>
											</h3>

										<p>  passed away on April 11, 2021 Shannon &#8216;Sam&#8217; Waldo                 
                 <a class="morelink" href="https://www.berthoudrecorder.com/obituary-shannon-sam-waldo/" rel="bookmark" title="Read :: Obituary: Shannon &#8216;Sam&#8217; Waldo">... Full Story</a></p>
                 
                 </div>

						
						<div class="excerpt">

						
												<a href="https://www.berthoudrecorder.com/obituary-betty-j-anderson/" rel="bookmark" title="Permanent Link to Obituary: Betty J. Anderson"><img src="https://www.berthoudrecorder.com/wp-content/themes/Recorder_final/cropper.php?src=/wp-content/uploads/2021/04/Betty-Anderson-Obit-52x75.jpg&amp;h=50&amp;w=50&amp;zc=1&amp;q=95" alt="Obituary: Betty J. Anderson" /></a>
											
											<h3><a href="https://www.berthoudrecorder.com/obituary-betty-j-anderson/" rel="bookmark" title="Read :: Obituary: Betty J. Anderson">
											Obituary: Betty J. &raquo;</a>
											</h3>

										<p>A private, family graveside service will take place with interment                 
                 <a class="morelink" href="https://www.berthoudrecorder.com/obituary-betty-j-anderson/" rel="bookmark" title="Read :: Obituary: Betty J. Anderson">... Full Story</a></p>
                 
                 </div>

												</div>  
		</div>

	    </div>
</div><!--close postsidebar--></div><!--end content-->
</div><!--close contentcontainer-->

  <div class="clearall"></div>

	<div id="footer">

		
<script type="text/javascript">tb_pathToImage = "https://www.berthoudrecorder.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://www.berthoudrecorder.com/wp-includes/js/thickbox/tb-close.png";</script>

		Site contents copyright &copy; 2022 	Recorder Online	except as noted. All rights reserved. | 107 queries in 0.379 seconds.
	</div>

</div><!--close maincontainer-->


</div><!--close wrapper-->
<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
try {
var pageTracker = _gat._getTracker("UA-11821241-1");
pageTracker._trackPageview();
} catch(err) {}</script>
<!-- VARVEE FOOTER -->
</body>
</html>